Follow

I have a message telling me that my smartphone is not compatible although it is properly equipped with Bluetooth 4.0

Under Android, having Bluetooth 4.0 is not enough. You must also have an operating system (OS) version able to function properly with Bluetooth 4.0 which is unfortunately not the case for Android versions below 4.4.  

Please check with the manufacturer of your smartphone to see if an update of the OS (4.4 or +) is available.

 

 


Your problem persists? Another question? Submit a request